Exporting Data from Eagle Point into Civil 3D

This document is intended for two main audiences:
e Eagle Point users who wish to share civil design data with Civil 3D users.
e Civil 3D users who wish to migrate legacy Eagle Point data.

What is LandXML? LandXML (Land Extensible Markup Language) is a data format
that allows civil, survey and other land development information to be shared between
applications. Many survey instruments, civil/survey CAD applications and GIS
applications can import and export LandXML files. Using LandXML, moving data is
very simple. For more information about LandXML visit www.landxml.org.

Using Land XML many objects created in Eagle Point can be transported into Civil 3D.
The following procedures can be used for 2007 through 2009 versions of Civil 3D.

Which objects do transfer:

¢ Alignments
Lots/ Parcels
Existing Ground Profile Data
Design Profile Data
Nodes/Points
Surfaces

Which objects do not transfer:
e Typical Sections/Assemblies
e Completed Roadways/Corridors
® Cross Section Data*

*On export, there is an option that appears to export cross sections but this functionality
is not fully implemented in Civil 3D.

& Data Transfer g|§| E| 1. In Eagle Point, launch the Data Transfer

) Module.
=== Formats  Report
Import File. .. 2. Go to Transfer > Export Land XML
Export Data. ..
Impark Land#ML, .

Export Land®ML. .. 3. In the Export Land XML Dialog Box click
the Edit drop-down.

Export SDMS/CAICE Foad Data...

Settings...

Figure 1
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v | [ Preview.. Item by item, we will work through the project and

Mew Alignment Group. .. gather the data we wish to export to LandXML.
Mews LokfParcel Group, ..

Mew Mode Group...
Mew Road Group...
Mew Surface Model Group...

4. Click New Alignment Group...

Fename Group...
Delete Group

Toaale Group For Preview

Figure 2

4F Select Alignments 5. In the New LandXML Alignment
Select alignment graphically or choose from list below il Group dlalog bOX’ CliCk SeleCt
MName 7 Sub-..  Drawing Pathname Allgnments'

Centerline
Offzet]
6. Select the Alignments you wish

to export.

You may use the LS”N key to select
oK J (e ], multiple Alignments at once.

Z1

Figure 3 .
7. Click OK

New LandXML Alignment Group @3] 8. Give the group a name to be used

Mame Sub-Project BOP Station Length EOP Station 1 1
Centerline om 0+00.00 1624.89 16+24.89 mn eXport’ and then Clle OK'
Oftsetl om 0+00.00 340.20 3+40.20
[ Select Alignments... ] [ Remove ]
Group Name: |Ahgnments wEDA |
[ Group Description | |
[ Group State:
[ 0Ok ] [ Cancel ] [ Apply }
Figure 4
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& Defined Lots 9. Back under the Edit dropdown,
Lot Group Lo v select New Lot/Parcel Group...

Mame Description D Owher Square Feet

10. In the New LandXML
Lot/Parcel Group, click Select
Lots

|~
| w

11. Select the lots you wish to
4 add to the data.

Figure 5
12.  Click OK.
New LandXML Lot/Parcel Group |E‘E|
Mame Description Area Perimeter Owner o 1
1 Marshall Subdivision  2735.91 21078 Peterson o 13' lee the Group a name and
2 Marshall Subdivizion  2989.61 21876 Fitzgerald 0z :
3 Marshall Subdivision 422115 260.26 ouTLoT 03 Clle OK.
4 tarshall Subdivision  5237.87 23062 Krutsen 04
5 Marshall Subdivision  8429.55 36164 Holland 05
[ Select Lats... ] [ Select Lot Group... ] [ Remove ]
Group Name: |Marshal| Subdivisior| |
[ Group Description | |
[ Group State:
[ 0Ok ] [ Cancel ] [ Apply }
.
Figure 6

Select Nodes 2] 14. Moving on to the points, select
Select Nodefs] To Exprt - New Node Group from the Edit
Selection Made (%) Select ) Unselect drOp-dOWﬂ menu (Flgure 2)

Selection Method: |AII w

15. Click Select Nodes.

16. In the Select Nodes dialog box
(Figure 7) verify that the Selection
Mode is set to Select

Tatal number of nodes selected: 1520

[ ok [ 4ppl ][ Cancel

17.  Change the Selection Method to
All

Figure 7

18. Click Apply.

19.  The number of points present in
the Eagle Point project should appear
near the bottom of the dialog box.

20.  Click OK.
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New LandXML Node Group 21. Give the point
MHode [0 Morthing E asting Elewation Description Field Code G gl’OUp a name.
1 9865.10 92115 958,53 GS 32 W
2 3074.97 923419 958,61 GS 32
Loome o omE o=n B g 22 All other
: 1553 i1 55 a8 = > settings shown in
; mr o=y o=Ze = x| FiguweSar
<9 9947 1R 7R 52 959 1A G5 kv r st Optlonal.
[ Select Nodes... ] [ Femove ]
Group Mame: |T0|30 Fointz | 23 . Cth OK
[ Growp Description: | |
[ Group State:
[ Code: | |
[] Zane Mumber: I:I
1 DTH dttributes:
QK ] [ Cancel ] [ Apply ]
Figure 8
24.  From the Edit menu

New LandXML Road Group

Select Sub-project:
BOP Station:
EQP Station:

0+00.00
1E6+24.89

Centerline D ata

Alignment: Centerling

Include Design Profile D ata

select New Road
Group.

001 - ROAD
Length:

1624.89

25. Select the
subproject you wish to

add from the pull-down

Include Original Ground Profile Data menu.
Ihzlude Crozs-Section Data Select Surfaces... ]
26. Toggle on all the
Group Name: Fioad 01 | available centerline data
[ Group Description: | | typeS as shown in
] Group State: Flgure 9.
[ 0k ] [ Cancel ] [ Apply ] .
27. Click OK.
Figure 9

Select Surface Models

PIX

Figure 10
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28. Lastly, we will add the surface model group to
the XML file.

29. Click New Surface Model Group from the Edit
menu.

30. Click Select Surface Models.

31. Select the surface models you wish to export and
click OK.
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New LandXML Surface Model Group 3 32. Give the group
Mame Hurn. Paints Mir. Elewvation Max Elewvation Plan &rea Suface Area a name and CliCk
Existing ... 1520 833.70 1028.61 3455681.43 3496567.71 OK
Fropozed 0 0.00 0.o0 0.o0 n.o0 .

[ Select Suface Models... ] [ Remove ]

Group Mame: |Existing and Propozed |

[ Group Description: | |

[ Group State:

QK ] [ Cancel ] [ Apply ]
Figure 11
Export LandXML At this point all the

Right click in the Land=<ML Explorer to add, modify or delete data to expart.

=23 Aligrments
& slignments w EOP
=23 Lote/Parcel: |

group names you
have created for

m Warshall Subdivision Description: Export to Civil 30
=3 MNodes Entended D escription: eXport ShOUld be.
o) a? LDDD Foints State: Exizting v ShOWH m the main
oads
R Road 01 Project Location: cohbest EXport LandXML
=43 Surface Models D ata Files Location: o hest s
@ Ewisting and Propozed | | dlalog bOX.
Plot Files Location: cohbest
Created By: Loviza &. Holland

E-mail Address:

| 33. Click on

| louiza. hollandi@imasterg. cam

Company: |MasterGraphics | Settings to
Company ‘Web Address: | . nagterg, com | Verlfy the unitS
Linear Units: Feet .« .
T S quare Foet and precision
Wolurne Units: Cubic: Feet approprlate to

Eagle Paint Software

Civil/Survey 2005

Edit... V|[ Freview... ][ Settings... ]

i, eaglepoint. com

E1.0

Figure 12
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your project.
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Export LandXML File Unit Settings

Units | Precision |

34. In the units tab, and

verify the current and

Linear Units

exported length setting.

Current Project units are: | Intemational Feet

Export Data File units as: | International Feet

Note that the default unit types

Uzing the conversion factor

| in both Eagle Point and Civil

[] Change conversion factor [

] 3D are International Feet with

Angular Urits

decimal angular degrees. Your

Direction/Angle: | Decimal Degrees

project may differ.

ak. ” Cancel ][

Apply

Figure 13

Export LandXML File Unit Settings

| Units | Precizion |

ax Precision

Morthing/E asting: I:‘ T
Elevation: EI T i
Distance: I:I T,
Station: l:l T
Offset: l:l .
Area I:‘ 7
Wolume: l:l . e
Surface Coordinates: I:I T
Surface Elevation I:‘ e
Angular [Decimal): l:l T
Angular [DMS): -
Ok ] [ Cancel ] [ Apply
Figure 14

37

Figure 15
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35.

36.

Save in: | 1) test v| o ? # ,
38.
39.
File name: |Convert to C30 . xml | [ Save l
Save as type: |Land><ML [*=ML) w | [ Cancel ]

On the Precision tab, verify that
Max Precision is checked on for all
geometry types.

Click OK to exit the Export
LandXML File Unit Settings

On the main Export LandXML
window, click Export.

Browse to your project directory,
and type in a name for the file.

Click Save.
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40. In Civil 3D, make sure you are

41. Go to File > Import > Import

s o S e T s e P

eTransmit...

Publish to Web...

D B

in a drawing that contains your styles and settings.

LandXML

et ey 0 = s e

-

Import
Export

Batch Converter...

-

I:IEI Page Setup Manager...

Import Data from Land Desktop...

C Import LandXML... )

Import Google Eartll?flmage...

Import Google Earth Surface...

e i P it Pt B B o R oy it it et S

Figure 16

A P el e gl At M Bl ook

AR - 40 Browse to the location of
Lookm: | ). TEST g FPPAXE = - Tk - the LandXML file and select

* | | Name Date taken Tags Size Rating it

l ’ (= Convert to C3dxml 1628 KB :

I\ 43, Click Open.

b

e

I

""} ] I | r

L . EET .
~| Fiesoftype: [LandXWL Cam) <) cancal |

i*“igure 17
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T Import LandXML [=3]
Alignments Site:
Parcels Site:
B Ste 1 -

[w] Project name:Export to Civil 30 state:proposed
Units {1)

CgFoints name: Topo Foints {1520)
Surfaces name:Existing and Proposed (1)
Parcels name:Marshall Subdivision (5)
Alignments name:Alignments w EQP (2)
Alignments name:Road 01 (1)

Application desc:Export Land¥ML manufacturer :Eagle Point Software manuf:

a1

Cancel ] ’

Help

Figure 18

The objects you are about to import
will appear in the list.

44. Verify the site you wish to
send your alignments and parcels.
If no site exists for parcels, it

will automatically default to Site
1.

% LandXML Settings

45. Click Edit LandXML
Settings...
46. In the Export tab,

Impart | Export l

verify the Data Settings.

Property
Identification
El Data Settings

Value

Be sure they match the
settings that were used
on export from Eagle

Irnperial Units

Angle / Direction format

international foot
degrees decimal (DDD.DDDDDD

Point.

Create Read-Only File off
Point Export Settings
Surface Export Settings
Parcel Export Settings
Alignment Export Settings

Figure 19

48.

49.

T PP TS PPN P S T PR A S SR PR T YN SUU T S T PSR CESEI P T

(In versions 2008 and prior,
there is a Data Conversion
setting in the Import Tab that
controls conversion from Survey
Feet to International Feet.)

47.  Click OK

Click OK on the Import LandXML dialog box.

You will soon see objects appear in their default styles. These are now true Civil

3D objects that can be manipulated as if they were native to the project.
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Profiles Corridors Sections Pipes

Ry Create Profile from Surface...

M Create Profile by Layout...
By  Create Profile from File...

== Quick Profile...

Create Profile View... lk

regte Multiple FroTile VIEws..,

Create Superimposed Prefile..

Edit Profile Geometry...
Design Criteria Editor...

Add Profile View Labels

Figure 20

J General
Station Range
Profile view Height

Profile Display Cptions
Figure 21

“GEngrEl C T
Station Range

Profile View Height

T

%| P Profile Display Options

A e e et ol

Select alignment:

B Certerine - 001 -

In the case of your profiles, a view needs to be made to
see the imported profile data.

50. Go to Profiles > Create Profile View.

51. Select the
Alignment that you’d
like to work with.

Profile view name:

«[Parent Alignment(CP)] > < [MNext Counter(CP)] =

Description:

[ By BT GRSy Gptibris? ™ 7 T T e e T T e 52 In the Profﬂe
Name Draw Clip Grid  Split At Description Type Da DlSplay Options
Design Centerline Design Pr... el area, Verify the

.

data you wish to

Figure 22

draw in your view.

Note that an existing ground profile pulled in from a LandXML file is not dynamic with
the surface model. You will want to uncheck any existing ground surfaces from the
Profile Display options and extract the profile from the surface model.

53. Click Create Profile View.

At this point, if you are going to continue working with the project in Civil 3D, you can
XREF the original Eagle Point base drawing into the Civil 3D project drawing.

Copyright 2008 MasterGraphics, Inc. Page 9 of 9



